#1694 Align various UI string formatting with the O.S.

Closed
opened 10 months ago by Moonchild · 3 comments

As a companion issue to MoonchildProductions/Basilisk#31 we should align several string in /toolkit that are currently formatted using ES Intl with the traditional DateTimeFormatter to pick up the O.S.‘s user-set formatting so it no longer reflects whatever language the applications are built in, but rather what is available and set by the user in the operating system to provide an as consistent as possible display.

This involves:

  • Date display in AM N/A because we are using TychoAM
  • Date display in cookie accept dialogs
  • Date display in updater history
As a companion issue to MoonchildProductions/Basilisk#31 we should align several string in `/toolkit` that are currently formatted using ES Intl with the traditional DateTimeFormatter to pick up the O.S.'s user-set formatting so it no longer reflects whatever language the applications are built in, but rather what is available and set by the user in the operating system to provide an as consistent as possible display. This involves: - ~~Date display in AM~~ N/A because we are using TychoAM - Date display in cookie accept dialogs - Date display in updater history
Moonchild added the
C: Places
label 10 months ago
Moonchild added the
C: UI
label 10 months ago
Moonchild added the
Localization
label 10 months ago
Moonchild added the
Regression
label 10 months ago
Moonchild self-assigned this 10 months ago
Moonchild added the
String Changes
label 10 months ago
Moonchild added the
Fixed
label 10 months ago

These two things should be verified (e.g. with an unstable Pale Moon).

These two things should be verified (e.g. with an unstable Pale Moon).

@alucard please take note of the added string and update the en-US source strings on CrowdIn accordingly.

@alucard please take note of the added string and update the en-US source strings on CrowdIn accordingly.

Verified the cookie details dialog and updater history respect the O.S.‘s settings.

Verified the cookie details dialog and updater history respect the O.S.'s settings.
Moonchild closed this issue 10 months ago
Moonchild added the
Verified
label 10 months ago
This repo is archived. You cannot comment on issues.
No Milestone
No Assignees
1 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.